secrets/flake.nix
Samuel Shuert f86634ca37 feat: Initialize cargo project and direnv
This is the first commit for the Aux Secrets project

Change-Id: Ifad1e4638aa8e30d5a1f4a9acdf0cf21350ecdde
2024-08-31 16:16:22 -04:00

43 lines
939 B
Nix

{
description = "The Auxolotl Secrets project";
inputs.flake-utils.url = "github:numtide/flake-utils";
inputs.fenix = {
url = "github:nix-community/fenix";
inputs.nixpkgs.follows = "nixpkgs";
};
inputs.nixpkgs.url = "github:nixos/nixpkgs/nixpkgs-unstable";
outputs =
{
nixpkgs,
flake-utils,
fenix,
...
}:
flake-utils.lib.eachDefaultSystem (
system:
let
pkgs = import nixpkgs {
inherit system;
overlays = [ fenix.overlays.default ];
};
in
{
devShells.default = pkgs.mkShell {
packages = [
(pkgs.fenix.stable.withComponents [
"cargo"
"clippy"
"rust-src"
"rustc"
"rustfmt"
"rust-analyzer"
])
pkgs.bacon
];
};
formatter = pkgs.nixfmt-rfc-style;
}
);
}