docs-site/flake.nix
Skyler Grey 295db9c69c
feat: Add nix package
We've used snowfall here to simplify writing our flake, as well as to
make it use a similar structure to auxolotl/website

BREAKING-CHANGE: This replaces bun with nodejs, as buildNpmPackage cannot take a bun.lockb
2024-05-17 00:59:16 +00:00

32 lines
695 B
Nix

{
description = "A documentation browser for Auxolotl";
inputs.flake-utils.url = "github:numtide/flake-utils";
inputs.snowfall-lib = {
url = "github:snowfallorg/lib";
inputs.nixpkgs.follows = "nixpkgs";
};
inputs.nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
inputs.wiki = {
url = "github:auxolotl/wiki";
flake = false;
};
outputs =
inputs:
inputs.snowfall-lib.mkFlake {
inherit inputs;
src = ./.;
alias.packages.default = "docs-site";
snowfall = {
root = ./nix;
namespace = "auxolotl--docs-site";
};
outputs-builder = channels: { formatter = channels.nixpkgs.nixfmt-rfc-style; };
};
}