isabel roses
c13b60bc67
We should reflect that we are now on Forgejo and have a different process to the Nixos organization for adding maintainers. Reviewed-on: #17 Reviewed-by: Coded <me@thecoded.prof> Co-authored-by: isabel <isabel@isabelroses.com> Co-committed-by: isabel <isabel@isabelroses.com>
53 lines
1.8 KiB
Nix
53 lines
1.8 KiB
Nix
/*
|
|
List of Aux maintainers.
|
|
```nix
|
|
handle = {
|
|
# Required
|
|
name = "Your name";
|
|
forgejo = "forgejoUsername";
|
|
forgejoId = your-forgejo-id;
|
|
|
|
# Optional, but at least one of email or matrix must be given
|
|
email = "address@example.org";
|
|
matrix = "@user:example.org";
|
|
|
|
keys = [{
|
|
fingerprint = "AAAA BBBB CCCC DDDD EEEE FFFF 0000 1111 2222 3333";
|
|
}];
|
|
};
|
|
```
|
|
|
|
where
|
|
|
|
- `handle` is the handle you are going to use in nixpkgs expressions,
|
|
- `name` is a name that people would know and recognize you by,
|
|
- `email` is your maintainer email address,
|
|
- `matrix` is your Matrix user ID,
|
|
- `forgejo` is your forgejo handle (as it appears in the URL of your profile page, `https://git.auxolotl.org/<userhandle>`),
|
|
- `forgejoId` is your forgejo user ID, which can be found at `https://git.auxolotl.org/api/v1/users/<username>`,
|
|
- `keys` is a list of your PGP/GPG key fingerprints.
|
|
|
|
`handle == forgejo` is strongly preferred whenever `forgejo` is an acceptable attribute name and is short and convenient.
|
|
|
|
If `forgejo` begins with a numeral, `handle` should be prefixed with an underscore.
|
|
```nix
|
|
_1example = {
|
|
forgejo = "1example";
|
|
};
|
|
```
|
|
|
|
Add PGP/GPG keys only if you actually use them to sign commits and/or mail.
|
|
|
|
To get the required PGP/GPG values for a key run
|
|
```shell
|
|
gpg --fingerprint <email> | head -n 2
|
|
```
|
|
|
|
!!! Note that PGP/GPG values stored here are for informational purposes only, don't use this file as a source of truth.
|
|
|
|
More fields may be added in the future, however, in order to comply with GDPR this file should stay as minimal as possible.
|
|
|
|
When editing this file, please ensure that you have added yourself in alphabetical order of your handle.
|
|
*/
|
|
{ }
|