core/lib/tests/check-eval.nix
2024-06-30 09:16:52 +01:00

11 lines
229 B
Nix

# Throws an error if any of our lib tests fail.
let
tests = [
"misc"
"systems"
];
all = builtins.concatLists (map (f: import (./. + "/${f}.nix")) tests);
in
if all == [ ] then null else throw (builtins.toJSON all)